Rear washer pump not working

Use this forum to discuss audio and electronic upgrades for your Isuzu

Moderator: Staff

Rear washer pump not working

Postby Wmamula04 » Sat May 15, 2021 7:25 pm

My rear windshield washer pump isnt working on my 91 trooper, just put a new one in cause the last one had a crack and didn’t work so it’s definitely a wiring issue. Does anyone know if it’s hooked up to any fuses or relays or have a wiring diagram?
Wmamula04
Drives on Pavement
 
Posts: 21
Joined: Tue Nov 24, 2020 2:46 pm
Location: Somewhere in Colorado
Has thanked: 2 times
Have thanks: 0 time

Sponsor
 

Re: Rear washer pump not working

Postby QuantumRift » Sun May 16, 2021 10:07 pm

Check wiring to/from it visually, look for bad or broken, missing ground.
"If Opportunity knocks and he's not at home, Opportunity waits."
"Find out what it is in life that you don't do well, then don't do that thing."

1990 Isuzu LS SpaceCab 4x4 (Japanese-built, September 1989)
226,000 miles original, unrebuilt engine.
K&N Air Filter
2.6 L 4ZE1 engine, 5-spd manual
Monroe Sensa-track Load Adjusting Shocks (rear)
Monroe OE Spectrum Shocks (front)
MagnaFlow Muffler & Cat Converter
Akebono ProACT Ultra-Premium Ceramic Brake Pads (front)
Wagner Thermoquiet Ceramic Brake Pads (rear)
Owned since 15 miles. Bought new Honolulu, HI in Oct '89.
Original sticker price: $15,000.
User avatar
QuantumRift
Almost Joe Isuzu
 
Posts: 2200
Joined: Mon Aug 06, 2012 5:46 pm
Location: Fairfield County, OH
Has thanked: 27 times
Have thanks: 112 times


Who is online

Users browsing this forum: No registered users and 0 guests