Instrument panel & parking lights do not work

Use this forum to discuss audio and electronic upgrades for your Isuzu

Moderator: Staff

Instrument panel & parking lights do not work

Postby Dagny » Sat Aug 01, 2020 10:38 pm

Hello, Gang--
Newbie here writing to get help! The incandescent lights for my instrument panel, climate control and glove box stopped working yesterday. The parking lights in front and back also do not work. Rotating the dimming switch does nothing. Pulled and checked all the fuses in the dash fuse box and they look fine. I don't know what to do next. Have any ideas??
Thanks!
Dagny
'97 Rodeo
Dagny
Drives on Pavement
 
Posts: 4
Joined: Thu Jul 23, 2020 9:16 am
Has thanked: 0 time
Have thanks: 0 time

Sponsor
 

Re: Instrument panel & parking lights do not work

Postby vtxstar » Thu Aug 06, 2020 4:20 pm

There are several possibilities.
I've got a 99 Rodeo/Amigo wiring book (genuine Isuzu book) and would need to know if your 97 has similar wiring.

You *did* check the bulbs to make sure they were good? (with a continuity tester)

For 98, all the Dash/Console lights brightness are passed thru an 'Illumination Controller'.
The diagram shows this as a solid state module. Notes say 'Do not check resistance'.
This unit controls the current from the Dash lamps and it is inserted between the lamps and the ground/return.

To quote from the circuit operation description:
The Tail/Illumi Light fuse applies battery voltage at all times to the taillight relay.
When the lighting switch is in the HEAD or PARK position, the lighting switch provides ground to the taillight relay.
The taillight relay energizes providing battery voltage to the dash and console lights.
The brightness of the lights is controlled by the illumination controller.
The illumination controller is a solid-state device which controls the ground path provided to the lights.


-=Doug
'IT ≠ IQ ' Starwalt 1999
1999 Rodeo LS
UEB7VF AJ/JI
Trooper 6VE1 under the hood!(I've got pictures!)
User avatar
vtxstar
Drives in Mud
 
Posts: 80
Joined: Mon Feb 22, 2016 4:04 pm
Location: Anderson, SC
Has thanked: 2 times
Have thanks: 6 times

Re: Instrument panel & parking lights do not work

Postby vtxstar » Fri Aug 07, 2020 4:47 pm

Here's a Haynes manual clip for 95 and later showing interior wiring...
You do not have the required permissions to view the files attached to this post.
'IT ≠ IQ ' Starwalt 1999
1999 Rodeo LS
UEB7VF AJ/JI
Trooper 6VE1 under the hood!(I've got pictures!)
User avatar
vtxstar
Drives in Mud
 
Posts: 80
Joined: Mon Feb 22, 2016 4:04 pm
Location: Anderson, SC
Has thanked: 2 times
Have thanks: 6 times

Re: Instrument panel & parking lights do not work

Postby Dagny » Sat Aug 08, 2020 11:55 am

This is helpful. Thanks for sending!
An update: the tail lights actually do NOT work when the headlights are on. Also, forgot to mention...in the past 3 months, I have had to replaced the right tail light bulb 2x for blowing which is out of the ordinary for this car. Not sure if that's relevant.
Digging around today.
Thanks again for your time and efforts!
Dagny
Dagny
Drives on Pavement
 
Posts: 4
Joined: Thu Jul 23, 2020 9:16 am
Has thanked: 0 time
Have thanks: 0 time


Return to Audio & Electronics

Who is online

Users browsing this forum: wuhuilin11 and 11 guests

cron