2001 Rodeo transmission trouble

Discuss anything related to drivetrain problems here (Engine, Transmission, etc)

Moderator: Staff

2001 Rodeo transmission trouble

Postby 45acp » Sun Apr 29, 2012 2:42 am

2001 Rodeo 4x4 3.2 auto
173,000
I have reverse only, wont go forward. Will go in winter mode (start in 3rd gear) only.
Added 1 qt fluid, no change.
Is the transmission shot?

Thanks for any ideas
45acp
Drives on Pavement
 
Posts: 3
Joined: Sun Apr 29, 2012 1:42 am
Has thanked: 0 time
Have thanks: 0 time

Sponsor
 

Re: 2001 Rodeo transmission trouble

Postby Buster28 » Sun Apr 29, 2012 6:25 am

The reaction sun drum brake band is applied in 1st and 2nd gear and is released in Park, Reverse, Neutral, 3rd and 4th gear. Since you have motion in Reverse, 3rd and 4th gears there is a possibility the brake band is slipping or the hydraulically operated piston that applies the brake band is not working.

It is also possible the 2-3 shift solenoid (Shift B) is defective and won't energize for 1st and 2nd gear operation. However, a defective solenoid should produce a CEL and a Check Trans indication. You can replace the solenoid without removing the transmission, you have to disassemble the transmission to replace the band.

The 1-2/3-4 shift solenoid (shift A) is energized in Winter Mode and is working because 3rd is available, the 2-3 shift solenoid (Shift B) is de-energized in 3rd and 4th which typically would be the failure state.
02 Rodeo Sport 4X4 3.2L V6 76K miles
01 Rodeo Sport 4X4 3.2L V6 48K miles
User avatar
Buster28
I am the Stig
 
Posts: 4322
Joined: Fri Dec 18, 2009 12:28 pm
Location: RI
Has thanked: 3 times
Have thanks: 405 times

Re: 2001 Rodeo transmission trouble

Postby 45acp » Sun Apr 29, 2012 3:48 pm

Thanks for the help. This is my son's truck. He said that it started about a week ago, had to rev engine in drive, then it would just pop into gear. I don't know if that helps in the diagnosis. I don't have a check trans light. The CEL is on but has been from another issue. Guess i can have codes read. Sounds like its worth a try at the shift B solenoid you memtion. Where is it? Looks like special order from autozone or should this be an OEM part? If its the drum brake band you memtion I assume that would be rebuild or replace? I don't know anything about transmissions.
Again thank you.

Update, had CEL code read but no trans codes. Will order the solenoid. It seems like when I start in winter mode I can downshift manually to 2nd but not first. I'm getting worried.
45acp
Drives on Pavement
 
Posts: 3
Joined: Sun Apr 29, 2012 1:42 am
Has thanked: 0 time
Have thanks: 0 time

Re: 2001 Rodeo transmission trouble

Postby dewzenol » Mon Apr 30, 2012 2:55 pm

My 98 Rodeo has the EXACT same symptoms. I have still been driving it around using the winter button to get going in high gear. Mine is not due to a solenoid, I'm sure. 1st will grab a little if you're already moving sometimes (it varies) but I'm afraid to do it because I thing I must be trashing it further, so I stick with the winter drive button. When it first went out, I limped to a meineke and had them change out the filter and fluid, and let me know what they found. All I learned was that the fluid was full of metal particles, according to them. I'm currently pricing a transmission rebuild.
FYI, this occurred at EXACTLY 200k.
Have a 98 Rodeo.
Had a 99 Trooper but it was hit by lightning. RIP
Have a 'new' 99 trooper now.
dewzenol
Drives on Pavement
 
Posts: 21
Joined: Sat May 01, 2010 3:18 am
Has thanked: 0 time
Have thanks: 0 time

Re: 2001 Rodeo transmission trouble

Postby 45acp » Mon Apr 30, 2012 10:36 pm

Yeah, I'm debating if I should try the solenoid along with filter change. Just don't want to spend $$ if I need to replace. Just got estimate on replacing with used. I hope Buster28 has more thoughts on it. Thanks.
45acp
Drives on Pavement
 
Posts: 3
Joined: Sun Apr 29, 2012 1:42 am
Has thanked: 0 time
Have thanks: 0 time

Re: 2001 Rodeo transmission trouble

Postby Buster28 » Tue May 01, 2012 6:50 am

If you have no transmission DTC(s) set and no flashing Check Trans lamp it is not likely you have a solenoid problem. Since you apparently can shift into 2nd gear the band is being applied but probably slips in 1st gear due to higher torque requirements.
02 Rodeo Sport 4X4 3.2L V6 76K miles
01 Rodeo Sport 4X4 3.2L V6 48K miles
User avatar
Buster28
I am the Stig
 
Posts: 4322
Joined: Fri Dec 18, 2009 12:28 pm
Location: RI
Has thanked: 3 times
Have thanks: 405 times

Re: 2001 Rodeo transmission trouble

Postby musicman51517 » Sat Jun 09, 2012 9:51 pm

I have the same problem on my 99 Trooper and I'm wondering if you did replace the solenoid and if it actually did the trick ?
I really don't want to put alot of time effort and money into this, if it is the tranny itself !!
musicman51517
Drives on Pavement
 
Posts: 4
Joined: Sat Jun 09, 2012 9:31 pm
Has thanked: 0 time
Have thanks: 0 time


Return to Drivetrain Problems

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests